股海明灯官网

 账号找回
 立即注册

QQ登录

只需一步,快速开始

广告载入中...
查看: 68223|回复: 937

关于成交量的源码通用代码(重要)

    [复制链接]
发表于 2010-2-5 09:11 | 显示全部楼层 |阅读模式

马上注册,享用更多功能,让你轻松玩转本论坛。

您需要 登录 才可以下载或查看,没有帐号?立即注册

x
本帖最后由 汉兵 于 2011-3-18 14:28 编辑

量柱擒涨停的核心在于看量柱识庄家,所以量柱标示、量柱选股都离不开量柱指标源码的调用特发布有关量柱的指标源码供大家学习使用。
成交量常用通式

      一、放量、缩量(成交量函数为VOL)
      1、放量:
      (1).今天成交量较昨天增加了1倍,表示如下:
         VOL/REF(VOL,1)>2
      (2).今天成交量较10个交易日平均成交量放大了1倍,表示如下:
      a:=ma(vol,10);
      Vol/a>2
      或者直接用如下公式表示:
      vol/ma(vol,10)>2;
      (3).今日的5日均量较10个交易日平均成交量放大了1倍,表示如下:
        a:=ma(vol,10);
      b:=ma(vol,5);
      b/a>2;
      (4).今日的成交量超过了整个流通盘的5%,表示如下:
         vol/capital>0.05;其中capital代表流通盘。
      2、缩量
        (1).今日成交量较昨日减少了一半,表示如下:
      vol/ref(vol,1)<0.5;
      (2).今日成交量较10个交易日平均成交量减少一倍,表示如下:
        a:=ma(vol,10);
      vol/a<2;
      或者直接用如下公式表示:
         vol/ma(vol,10)<2;
      (3).今日的5日均量较10个交易日平均成交量减少1倍,表示如下:
      a:=ma(vol,10);
      b:=ref(a,5);
      a/b<2;
      (4).今日的成交量低于了整个流通盘的5%,表示如下:
      vol/capital<0.05;

评分

1

查看全部评分

帖子永久地址: 


楼主热帖
[量友问答] 我们很庆幸和王子老师同时代
[新人新帖] 如何根据自己的情况学习股票投资知识
[举报骗子] 抢注股海明灯商标行骗的“吴振锋”被“闪电网
[新人新帖] 阴阳量学理论的综合运用 昇昇
[股票公式] 券商版中的量柱公式(通达信)
[股票研讨] 个人财务状况稳健的34个迹象(转载)
[股票研讨] 聪明?(转帖)
[股票研讨] 颠覆你的股市投资理念(转帖)
[股票研讨] 股票图书市场观察:“卖铲子”的太多了(转帖
[股票研讨] A股低迷的真正内因及市场对策 (转帖)
[股票研讨] 高手们用的大盘K线指标
[股票研讨] 高手(zt)

本帖被以下淘专辑推荐:

回复 论坛版权

使用道具 举报

发表于 2016-1-7 19:03 | 显示全部楼层
{VOL_量柱} {看图说明:黄色为倍量柱,白色为并肩平量柱,紫色为缩倍柱, 绿色为10天低量柱,蓝色为50天低量柱,灰色为百日低量柱, 高量柱容易看无标记,!为长阴短柱, 内有红实线为假阴柱。 红色箭头(的前三天)为黄金柱。次黄金柱难判,不标记} {=====================================================} 绿低量:=10;{WWW.178448.COM WEN98编制} 蓝低量:=50; 灰低量:=100; H_L:=0.1*CONST(HHV(VOL,240)); {MAV10:MA(V,10),COLORYELLOW;} 异动135:MA(V,135),COLORMAGENTA; 洗盘40:MA(V,40),COLORBLUE; 启动5:MA(V,5),COLORWHITE; VVOL:=IF(CURRBARSCOUNT=1 AND PERIOD=5,VOL*240/FROMOPEN,DRAWNULL);{模拟量} STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,VVOL,0,1,-1),COLOR00C0C0; 量:VOL,VOLSTICK,COLORLIGRAY; 换手: VOL*10000/FINANCE(7),NODRAW,COLORGREEN; {DYNAINFO(37)*100} 全换手周期: SUMBARS(V,CAPITAL),NODRAW,COLORLIGREEN;{求完全换手到现在的周期数} 量比: V/REF(MA(V,5),1),COLORBROWN,NODRAW; 几倍: V/REF(V,1),COLORYELLOW,NODRAW; 倍数:=1.9; 倍量: VOL>=REF(V,1)*倍数 AND (IF(C<O,C>REF(C,1),1)),COLORYELLOW,NODRAW; 倍缩: REF(V,1)>=VOL*倍数,COLORMAGENTA,NODRAW; 平量: RANGE(V/REF(V,1),0.97,1.03) AND BARSCOUNT(V)>=2,COLORWHITE,NODRAW; 低量10: VOL=LLV(VOL,绿低量) AND BARSCOUNT(V)>=绿低量,COLORGREEN,NODRAW; 低量50: VOL=LLV(VOL,蓝低量) AND BARSCOUNT(V)>=蓝低量,COLORBLUE,NODRAW; 地量:   VOL=LLV(VOL,灰低量) AND BARSCOUNT(V)>=灰低量,COLORGRAY,NODRAW; V1:=VOL*0.95;{图标位置} V2:=VOL*0.85; STICKLINE(倍量, 0,V1,1,0),COLORYELLOW; STICKLINE(平量,0,V1,1,0),COLORWHITE; STICKLINE(低量10,0,V2,1,0),COLORLIGREEN; STICKLINE(低量50,0,V2,1,0),COLORBLUE; STICKLINE(地量,0,V2,1,0),COLORGRAY; STICKLINE(倍缩,0,V*0.45,1,0),COLORMAGENTA; STICKLINE(C<O AND C>REF(C,1),0,V1,0,0),COLORRED;{假阴柱}  真阳或假阴:=C>O OR C>REF(C,1); 收阳:= REF(真阳或假阴,3); 倍量1:=REF(倍量,3);  高量:=REF(V,3)>=HHV(V,7); 三日不破:= LLV(C,3)>=REF(L,3); 价升:=COUNT(C>=REF(C,1),3)=3;{收盘价逐升} 量缩:=COUNT(V<=REF(V,1),3)=3; 连阳:= COUNT(真阳或假阴,3)=3; 倍量将军柱:= 倍量1 AND 三日不破 AND 收阳; 高量将军柱:= 高量  AND 三日不破 AND 收阳; 将军柱:= 倍量将军柱 OR 高量将军柱; 黄金柱:= 将军柱 AND 价升 AND 量缩 AND 连阳 ;{标准黄金柱} STICKLINE(黄金柱,0.3*V,0.7*V,1,0),COLORRED; {红柱} DRAWICON(黄金柱,V*1.5,1); V100:= V<=LLV(V,100)*1.2 AND V>0 AND BARSCOUNT(V)>=100; 百日地量群:=COUNT(V100,5)>=3; DRAWTEXT(FILTER(百日地量群,4),V+3*H_L,'地量群'),COLORGRAY; 长阴短柱:=C/REF(C,1)<=0.96 AND V<HHV(V,30)/1.9; DRAWTEXT(长阴短柱 ,V+1.6*H_L,'!'),COLORLICYAN;  {----VOL.量能饱和----不喜欢可删去下面语句----} N1:=21; SAT:=(AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20)); 量能饱和:IF(SAT>1,1,SAT)*100,COLOR00AAFF,NODRAW; 中点:=REFDATE(HHV(V,180)*0.5,DATE); STICKLINE(CURRBARSCOUNT=N1,中点*1.9,中点*1.5,100,1),COLOR00AAFF; STICKLINE(CURRBARSCOUNT=N1,中点*1.88,中点*1.52,量能饱和,0),COLOR0077FF; DRAWTEXT(CURRBARSCOUNT=N1+3,中点*1.7,'饱和度'),COLORYELLOW;
回复

使用道具 举报

发表于 2015-11-28 22:53 | 显示全部楼层
{VOL_量柱}
{看图说明:黄色为倍量柱,白色为并肩平量柱,紫色为缩倍柱,
绿色为10天低量柱,蓝色为50天低量柱,灰色为百日低量柱,
高量柱容易看无标记,!为长阴短柱, 内有红实线为假阴柱。
红色箭头(的前三天)为黄金柱。次黄金柱难判,不标记}
{=====================================================}
绿低量:=10;{WWW.178448.COM WEN98编制}
蓝低量:=50;
灰低量:=100;
H_L:=0.1*CONST(HHV(VOL,240));
{MAV10:MA(V,10),COLORYELLOW;}
异动135:MA(V,135),COLORMAGENTA;
洗盘40:MA(V,40),COLORBLUE;
启动5:MA(V,5),COLORWHITE;
VVOL:=IF(CURRBARSCOUNT=1 AND PERIOD=5,VOL*240/FROMOPEN,DRAWNULL);{模拟量}
STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,VVOL,0,1,-1),COLOR00C0C0;
量:VOL,VOLSTICK,COLORLIGRAY;
换手: VOL*10000/FINANCE(7),NODRAW,COLORGREEN; {DYNAINFO(37)*100}
全换手周期: SUMBARS(V,CAPITAL),NODRAW,COLORLIGREEN;{求完全换手到现在的周期数}
量比: V/REF(MA(V,5),1),COLORBROWN,NODRAW;
几倍: V/REF(V,1),COLORYELLOW,NODRAW;
倍数:=1.9;
倍量: VOL>=REF(V,1)*倍数 AND (IF(C<O,C>REF(C,1),1)),COLORYELLOW,NODRAW;
倍缩: REF(V,1)>=VOL*倍数,COLORMAGENTA,NODRAW;
平量: RANGE(V/REF(V,1),0.97,1.03) AND BARSCOUNT(V)>=2,COLORWHITE,NODRAW;
低量10: VOL=LLV(VOL,绿低量) AND BARSCOUNT(V)>=绿低量,COLORGREEN,NODRAW;
低量50: VOL=LLV(VOL,蓝低量) AND BARSCOUNT(V)>=蓝低量,COLORBLUE,NODRAW;
地量:   VOL=LLV(VOL,灰低量) AND BARSCOUNT(V)>=灰低量,COLORGRAY,NODRAW;
V1:=VOL*0.95;{图标位置}
V2:=VOL*0.85;
STICKLINE(倍量, 0,V1,1,0),COLORYELLOW;
STICKLINE(平量,0,V1,1,0),COLORWHITE;
STICKLINE(低量10,0,V2,1,0),COLORLIGREEN;
STICKLINE(低量50,0,V2,1,0),COLORBLUE;
STICKLINE(地量,0,V2,1,0),COLORGRAY;
STICKLINE(倍缩,0,V*0.45,1,0),COLORMAGENTA;
STICKLINE(C<O AND C>REF(C,1),0,V1,0,0),COLORRED;{假阴柱}

真阳或假阴:=C>O OR C>REF(C,1);
收阳:= REF(真阳或假阴,3);
倍量1:=REF(倍量,3);
高量:=REF(V,3)>=HHV(V,7);
三日不破:= LLV(C,3)>=REF(L,3);
价升:=COUNT(C>=REF(C,1),3)=3;{收盘价逐升}
量缩:=COUNT(V<=REF(V,1),3)=3;
连阳:= COUNT(真阳或假阴,3)=3;
倍量将军柱:= 倍量1 AND 三日不破 AND 收阳;
高量将军柱:= 高量  AND 三日不破 AND 收阳;
将军柱:= 倍量将军柱 OR 高量将军柱;
黄金柱:= 将军柱 AND 价升 AND 量缩 AND 连阳 ;{标准黄金柱}
STICKLINE(黄金柱,0.3*V,0.7*V,1,0),COLORRED; {红柱}
DRAWICON(黄金柱,V*1.5,1);
V100:= V<=LLV(V,100)*1.2 AND V>0 AND BARSCOUNT(V)>=100;
百日地量群:=COUNT(V100,5)>=3;
DRAWTEXT(FILTER(百日地量群,4),V+3*H_L,'地量群'),COLORGRAY;
长阴短柱:=C/REF(C,1)<=0.96 AND V<HHV(V,30)/1.9;
DRAWTEXT(长阴短柱 ,V+1.6*H_L,'!'),COLORLICYAN;

{----VOL.量能饱和----不喜欢可删去下面语句----}
N1:=21;
SAT:=(AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20));
量能饱和:IF(SAT>1,1,SAT)*100,COLOR00AAFF,NODRAW;
中点:=REFDATE(HHV(V,180)*0.5,DATE);
STICKLINE(CURRBARSCOUNT=N1,中点*1.9,中点*1.5,100,1),COLOR00AAFF;
STICKLINE(CURRBARSCOUNT=N1,中点*1.88,中点*1.52,量能饱和,0),COLOR0077FF;
DRAWTEXT(CURRBARSCOUNT=N1+3,中点*1.7,'饱和度'),COLORYELLOW;
回复

使用道具 举报

发表于 2016-5-17 23:46 | 显示全部楼层
绿低量:=10;{WWW.178448.COM WEN98编制}
蓝低量:=50;
灰低量:=100;
H_L:=0.1*CONST(HHV(VOL,240));
{MAV10:MA(V,10),COLORYELLOW;}
异动135:MA(V,135),COLORMAGENTA;
洗盘40:MA(V,40),COLORBLUE;
启动5:MA(V,5),COLORWHITE;
VVOL:=IF(CURRBARSCOUNT=1 AND PERIOD=5,VOL*240/FROMOPEN,DRAWNULL);{模拟量}
STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,VVOL,0,1,-1),COLOR00C0C0;
量:VOL,VOLSTICK,COLORLIGRAY;
换手: VOL*10000/FINANCE(7),NODRAW,COLORGREEN; {DYNAINFO(37)*100}
全换手周期: SUMBARS(V,CAPITAL),NODRAW,COLORLIGREEN;{求完全换手到现在的周期数}
量比: V/REF(MA(V,5),1),COLORBROWN,NODRAW;
几倍: V/REF(V,1),COLORYELLOW,NODRAW;
倍数:=1.9;
倍量: VOL>=REF(V,1)*倍数 AND (IF(C<O,C>REF(C,1),1)),COLORYELLOW,NODRAW;
倍缩: REF(V,1)>=VOL*倍数,COLORMAGENTA,NODRAW;
平量: RANGE(V/REF(V,1),0.97,1.03) AND BARSCOUNT(V)>=2,COLORWHITE,NODRAW;
低量10: VOL=LLV(VOL,绿低量) AND BARSCOUNT(V)>=绿低量,COLORGREEN,NODRAW;
低量50: VOL=LLV(VOL,蓝低量) AND BARSCOUNT(V)>=蓝低量,COLORBLUE,NODRAW;
地量:   VOL=LLV(VOL,灰低量) AND BARSCOUNT(V)>=灰低量,COLORGRAY,NODRAW;
V1:=VOL*0.95;{图标位置}
V2:=VOL*0.85;
STICKLINE(倍量, 0,V1,1,0),COLORYELLOW;
STICKLINE(平量,0,V1,1,0),COLORWHITE;
STICKLINE(低量10,0,V2,1,0),COLORLIGREEN;
STICKLINE(低量50,0,V2,1,0),COLORBLUE;
STICKLINE(地量,0,V2,1,0),COLORGRAY;
STICKLINE(倍缩,0,V*0.45,1,0),COLORMAGENTA;
STICKLINE(C<O AND C>REF(C,1),0,V1,0,0),COLORRED;{假阴柱}

真阳或假阴:=C>O OR C>REF(C,1);
收阳:= REF(真阳或假阴,3);
倍量1:=REF(倍量,3);
高量:=REF(V,3)>=HHV(V,7);
三日不破:= LLV(C,3)>=REF(L,3);
价升:=COUNT(C>=REF(C,1),3)=3;{收盘价逐升}
量缩:=COUNT(V<=REF(V,1),3)=3;
连阳:= COUNT(真阳或假阴,3)=3;
倍量将军柱:= 倍量1 AND 三日不破 AND 收阳;
高量将军柱:= 高量  AND 三日不破 AND 收阳;
将军柱:= 倍量将军柱 OR 高量将军柱;
黄金柱:= 将军柱 AND 价升 AND 量缩 AND 连阳 ;{标准黄金柱}
STICKLINE(黄金柱,0.3*V,0.7*V,1,0),COLORRED; {红柱}
DRAWICON(黄金柱,V*1.5,1);
V100:= V<=LLV(V,100)*1.2 AND V>0 AND BARSCOUNT(V)>=100;
百日地量群:=COUNT(V100,5)>=3;
DRAWTEXT(FILTER(百日地量群,4),V+3*H_L,'地量群'),COLORGRAY;
长阴短柱:=C/REF(C,1)<=0.96 AND V<HHV(V,30)/1.9;
DRAWTEXT(长阴短柱 ,V+1.6*H_L,'!'),COLORLICYAN;

{----VOL.量能饱和----不喜欢可删去下面语句----}
N1:=21;
SAT:=(AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20));
量能饱和:IF(SAT>1,1,SAT)*100,COLOR00AAFF,NODRAW;
中点:=REFDATE(HHV(V,180)*0.5,DATE);
STICKLINE(CURRBARSCOUNT=N1,中点*1.9,中点*1.5,100,1),COLOR00AAFF;
STICKLINE(CURRBARSCOUNT=N1,中点*1.88,中点*1.52,量能饱和,0),COLOR0077FF;
DRAWTEXT(CURRBARSCOUNT=N1+3,中点*1.7,'饱和度'),COLORYELLOW;
回复

使用道具 举报

发表于 2010-2-5 09:19 | 显示全部楼层
谢谢分享,学习
回复

使用道具 举报

 楼主| 发表于 2010-2-5 11:24 | 显示全部楼层
看来要代码的多 学代码的少 其实成交量的代码最少是最容易掌握的代码,没办法急功近利不愿学习那就等别人编好了再用吧!
回复

使用道具 举报

发表于 2010-2-6 14:46 | 显示全部楼层
学分已支付,请查收
回复

使用道具 举报

发表于 2010-2-7 23:40 | 显示全部楼层
谢谢分享,学习
回复

使用道具 举报

发表于 2010-2-9 19:55 | 显示全部楼层
谢谢分享,学习
回复

使用道具 举报

发表于 2010-2-11 18:04 | 显示全部楼层
学分已支付,请查收!!!
回复

使用道具 举报

发表于 2010-3-12 11:10 | 显示全部楼层
谢谢分享,学习
回复

使用道具 举报

发表于 2010-3-15 19:14 | 显示全部楼层
学习学习.谢谢分享.
回复

使用道具 举报

发表于 2010-4-23 17:46 | 显示全部楼层
谢谢楼主分享,已购买,学习了。
回复

使用道具 举报

发表于 2010-4-23 18:13 | 显示全部楼层
谢谢分享,学习
回复

使用道具 举报

发表于 2010-4-23 18:21 | 显示全部楼层
谢谢分享!!!!!!!!!!!
回复

使用道具 举报

发表于 2010-4-23 18:25 | 显示全部楼层
学分已支付,请查收!!!
回复

使用道具 举报

发表于 2010-4-23 20:48 | 显示全部楼层
回复 1# 汉兵


   
回复

使用道具 举报

发表于 2010-4-29 08:24 | 显示全部楼层
谢谢分享,学习
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

本站内容均为会员发表,并不代表本论坛立场! 免责声明
拒绝任何人以任何形式在本论坛发表与中华人民共和国法律相抵触的言论!
值班电话[8:30~17:30]: 010-51298846 15600356448(紧急)  010-51663518(广告)

Archiver|手机版|小黑屋|股海明灯量学官网 ( 京ICP备13001760号

GMT+8, 2017-7-22 10:47 , Processed in 0.181918 second(s), 20 queries , Gzip On, Memcache On.

Powered by Discuz! X3.1

© 2001-2013 Comsenz Inc.

快速回复 返回顶部 返回列表